[Dropbox] Dropbox Chat unavailable

Incident Report for Graebert Internal

Resolved

Vendor: Dropbox
Status Page: https://status.dropbox.com/

Nov 14, 21:11 UTC
Resolved - This incident has been resolved.

Nov 14, 20:00 UTC
Investigating - Dropbox Chat is currently unavailable, we are investigating the issue.

Posted Dec 06, 2025 - 20:25 UTC
This incident affected: Kudo Storages (Dropbox).