Sep 18, 17:12 PDT
Resolved - After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Sep 18, 15:59 PDT
Update - We are continuing to monitor for any additional impact.
Sep 18, 14:55 PDT
Monitoring - Our team has taken steps to remediate this issue and is seeing improvement for multiple Box Services. We are continuing to monitor for any additional impact.
Sep 18, 13:50 PDT
Investigating - Our team is investigating an issue with multiple Box Services. Users may see errors or slowness when attempting to access Box. We will provide additional information as it becomes available.