[Onshape] Unable to open documents

Incident Report for Graebert Internal

Resolved

Vendor: Onshape
Status Page: https://status.onshape.com/

Nov 25, 06:20 EST
Resolved - This incident has been resolved.

Nov 25, 05:45 EST
Monitoring - A fix has been implemented and we are monitoring the results.

Nov 25, 05:33 EST
Identified - The issue has been identified and a fix is being implemented.

Nov 25, 05:16 EST
Investigating - We are currently investigating alerts around opening documents

Posted Dec 06, 2025 - 20:25 UTC
This incident affected: Kudo Storages (Onshape).