[Dropbox] DocSend impacted by ongoing Cloudflare outage

Incident Report for Graebert Internal

Resolved

Vendor: Dropbox
Status Page: https://status.dropbox.com/

Nov 18, 14:53 UTC
Resolved - This incident has been resolved.

Nov 18, 14:38 UTC
Identified - We are aware that DocSend has been impacted by the ongoing Cloudflare outage

Posted Dec 06, 2025 - 20:25 UTC
This incident affected: Kudo Storages (Dropbox).