[Teachable] Student Experience Downtime

Incident Report for Graebert Internal

Resolved

Vendor: Teachable
Status Page: https://www.teachablestatus.com/

Nov 10, 13:15 EST
Resolved - This incident has been resolved. We received reports of some customers intermittently unable to load their Student Hub pages. The underlying issue has been corrected, and we’ll continue to actively monitor to ensure full stability.

Nov 10, 12:18 EST
Investigating - We are currently experiencing downtime with our student facing pages. We have identified the issue and we are actively attempting to resolve the issue.

Posted Dec 06, 2025 - 20:25 UTC
This incident affected: Third Party Services (Teachable).