[FastSpring] PayPal down

Incident Report for Graebert Internal

Resolved

Vendor: FastSpring
Status Page: https://status.fastspring.com/

Oct 16, 17:33 UTC
Resolved - We are no longer seeing the error in our logs and PayPal orders are completing successfully

Oct 16, 16:54 UTC
Investigating - FastSpring has received alerts confirming that PayPal is down.
We will continue to monitor and will update you with changes.

Posted Dec 06, 2025 - 20:24 UTC
This incident affected: Third Party Services (FastSpring).