[Teachable] Cloudflare issues downstream impact

Incident Report for Graebert Internal

Resolved

Vendor: Teachable
Status Page: https://www.teachablestatus.com/

Nov 18, 17:07 EST
Resolved - This incident has been resolved. We will continue to actively monitor our services and provide updates if anything changes.

Nov 18, 10:38 EST
Monitoring - All areas of the Teachable platform experiencing downstream impact from today’s Cloudflare outage have been restored. We will continue to monitor performance throughout the day. More info: https://www.cloudflarestatus.com/

Nov 18, 09:16 EST
Update - Due to a Cloudflare outage, we are experiencing downstream impact on the Teachable platform.
More info: https://www.cloudflarestatus.com/

The following areas are currently experiencing degraded or no service:
• Logging into the Teachable admin area
• Accessing student content (desktop and mobile)
• Checkout pages and purchasing

We will provide updates as we work to restore services.
We apologize for the inconvenience and appreciate your patience.

Nov 18, 08:25 EST
Identified - Due to a Cloudflare outage, we are experiencing downstream impact on our platform. Customers may continue to see latency and error rates. We apologize for the inconvenience and thank you for your patience.

Posted Dec 06, 2025 - 20:25 UTC
This incident affected: Third Party Services (Teachable).