[Teachable] Cloudflare Outage — Teachable Traffic Disruption (2025-12-05 04:50–05:10 ET)

Incident Report for Graebert Internal

Resolved

Vendor: Teachable
Status Page: https://www.teachablestatus.com/

Dec 5, 05:30 EST
Resolved - Incident Summary
Between 4:50am and 5:10am ET, Teachable experienced a brief period of unavailability. During this time, some visitors were unable to access teachable.com and related domains.

What Happened
A widespread outage at our upstream network provider, Cloudflare, temporarily disrupted traffic to Teachable. Because we route traffic through Cloudflare for security and performance, their outage prevented requests from reaching our platform.

Impact
Users may have encountered errors or been unable to load Teachable during the 20-minute window.

Resolution
Cloudflare resolved the issue, and access to Teachable was fully restored. No action was required from users, and all systems have remained stable since.

Reference
For transparency, Cloudflare’s public incident report is available here: Cloudflare Incident Report

Posted Dec 06, 2025 - 20:25 UTC
This incident affected: Third Party Services (Teachable).