[Dropbox] Dropbox is not working as expected for some users.

Incident Report for Graebert Internal

Resolved

Vendor: Dropbox
Status Page: https://status.dropbox.com/

Sep 23, 19:17 UTC
Resolved - This incident has been resolved.

Sep 23, 19:10 UTC
Update - We are continuing to investigate this issue.

Sep 23, 18:55 UTC
Investigating - We’re having some trouble with our services currently. We’re working to fix the problem as quickly as we can.

Posted Dec 06, 2025 - 20:25 UTC
This incident affected: Kudo Storages (Dropbox).